新宝4-新宝4注册-新宝4登录-新宝4网址,免费股票公式,股票软件下载站 用户登录  |  用户 注册
大智慧的分时主图指标源码
  • 软件大??:15.0 KB
  • 推荐星级:
  • 更新时间:2018-07-08 02:53:42
  • 软件类别: 国产软件 / 大智慧L2公式
  • 软件语言:简体中文
  • 授权方式: 共享软件
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win2000/WinXP/Win2003/WinVista
  • 相关Tags:股票公式 股票软件
  • (0)0%
    (0)0%

==

大智慧的分时主图指标源码

源码如下

BU:=BARSLAST(CLOSE=HHV(CLOSE,60));
SE:=BARSLAST(CLOSE=LLV(CLOSE,60));
KK1:=SE;
KK2:=BU;
LM1:=SE;
LM2:=BU;
OK:=KK1>KK2 AND LM1>LM2;
OK1:=KK1>KK2 AND LM1<LM2;
NOK:=KK2>KK1 AND LM2>LM1;
NOK1:=KK2>KK1 AND LM2<LM1;
DRAWICON(CROSS(KK1,KK2),OPEN*1,1);
DRAWTEXT(CROSS(KK1,KK2),OPEN*0.985,'抓'),color3cb371;
T:=barscount(c);
均价:=DYNAINFO(11);
总量:=SUM(VOL,T);
总额:=SUM(AMOUNT,T);
均价:=总额/(总量*100);
次数:=COUNT(CLOSE>均价,T);
占比:=次数/T*100;
分时强势:DRAWICON(CROSS(CLOSE,均价) AND CLOSE>均价 AND 占比>80 AND T>5,CLOSE*0.99,7);
DRAWTEXT(CROSS(CLOSE,均价) AND CLOSE>均价 AND 占比>80 AND T>5,CLOSE*0.98,'涨价'),colorFFFF00;
VAR1:=AMOUNT/VOL/100;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,5)/VAR1/100;
VAR4:=SUM(AMOUNT,13)/VAR1/100;
VAR5:=SUM(AMOUNT,34)/VAR1/100;
CYC5:=DMA(VAR2,VOL/VAR3);
CYC13:=DMA(VAR2,VOL/VAR4);
CYC34:=DMA(VAR2,VOL/VAR5);
CYC∞:=DMA(VAR2,VOL/CAPITAL);
一剑封喉:=CROSS(CLOSE,MA(CLOSE,13)) AND CROSS(CLOSE,MA(CLOSE,34)) AND CROSS(CLOSE,MA(CLOSE,55));
A1:=(CLOSE-LLV(LOW,22))/(HHV(HIGH,22)-LLV(LOW,22))*100;
A2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
A:=3*SMA(A1,5,1)-2*SMA(SMA(A2,5,1),3,1);
YNGS:=一剑封喉 AND A<30;
DRAWICON(一剑封喉 AND A<30,LOW*0.985,10);
DRAWTEXT(一剑封喉 AND A<30,LOW*0.98,'停'),colorFF0000;
{明关键价位}
c1:=ref(c,1);
c2:=hhv(c1,2);
c3:=llv(c1,1);
et:=hhv(c1,2);
et1:=ref(et,1);
xb:=llv(c1,1);
xb1:=ref(xb,1);
m:=BARSLAST(c<xb and c1>=xb1);
m11:=ref(m,1);
n9:=BARSLAST(c>et and c1<=et1);
n1:=ref(n9,1);
m21:=BARSLAST(m-n9>0 and m11<=n1)+1;
n2:=BARSLAST(n9-m>0 and n1<=m11)+1;
et2:=hhv(et,m21);
xb2:=llv(xb,n2);
a:=if(m-n9>0 and m11<=n1,1,if(n9-m>0 and n1<=m11,0,2));
h1:=if(m-n9>0,c,et2);
h2:=if(a=1,c,c2);
h3:=if(m-n9<0,c,xb2);
h4:=if(a=1,c,xb2);
h5:=if(m-n9>0 or a=1,c,h3);
明关键价位:ref(h5,1);
MA1:=MA(CLOSE,2);
Var1:=MA(C, 1);
Var2:=MA(C, 5);
Var3:=MA(C, 10);
Var4:=MA(C, 20);
Var5:=MA(C, 30);
Var6:=(Var1+Var2+Var3+Var4+Var5)/5;
Var7:=(Var6-REF(Var6, 15))/REF(Var6,15)*100;
Var8:=(Var6-REF(Var6, 15))/REF(Var6, 15)*100;
Var9:=EMA(Var7, 8);
平均价:=(H+4*L+C+O)/7;
均价差:= EMA(平均价,13) - EMA(平均价,34);
移动均价:= EMA(均价差,5);
差:=(均价差-移动均价)*5;
A:=IF(差>=1000 ,1000 ,if(差<=平均价,平均价,差) );
分水岭:=FORCAST(FORCAST(A,31),10);
涨↑:if(A>分水岭,A,分水岭),LINETHICK1,colorred;
跌↓:if(A<分水岭,A,分水岭),LINETHICK1,ColorGREEN;
ma6:=MA(c,6);
ma18:=MA(c,18);
ma55:=MA(c,55);
ma125:=MA(c,125);
ma250:=MA(c,250);
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=filter(A1,10); C1:=ref(B1,10+1); HD:=filter(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=filter(A2,10); C2:=ref(B2,10+1); LD:=ref(C2,10);
AA:=REF(c,barslast(HD)); B:=ref(c,barslast(LD));
t11:=barslast(HD)<barslast(LD) AND not(HD) ;
t21:=barslast(HD)>barslast(LD) AND not(LD);
波峰:if(t11,AA,AA),ColorFF00FF,pointdot;
stickline(t11,AA,AA,9,0),ColorFF00FF;
波谷:if(t21,B,B),Color80FF00,pointdot;
stickline(t21,B,B,9,0),Color80FF00;
买进价:=((c-ref(ma6,1))/6+ma6)*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
黄点状线:if(买进条件,h,l),COLORYELLOW,linethick1,pointdot;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWTEXT(IF(B1>0,1,0),L-0.1,'MACD底背'),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);
DRAWTEXT(IF(B2>0,1,0),L-0.25,'KDJ底背'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);
DRAWTEXT(IF(B3>0,1,0),L-0.4,'RSI底背'),COLORCYAN;
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(IF(D1>0,1,0),H*1.01,'MACD顶背'),COLORWHITE;
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);
DRAWTEXT(IF(D2>0,1,0),H+0.15,'KDJ顶背'),COLORWHITE;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(IF(D3>0,1,0),H+0.1,'RSI顶背'),COLORMAGENTA;
ref(h,C1),colorB48246,pointdot;
KK:=DATE<1341231;
PK:=VOL*(OPEN+CLOSE+HIGH+LOW)/4;
PK1:=IF(VOL>0,PK/VOL,(OPEN+CLOSE+HIGH+LOW)/4);
C11:=PK1;
A01:=(C11-LLV(C11,75))/(HHV(C11,75)-LLV(C11,75));
A11:=SMA(A01,13,1);
A21:=SMA(A11,13,1);
A31:=3*A11-2*A21;
A41:=2*A31-0.5;
ZS:=DYNAINFO(3)*0.95;
选1:=IF(KK,C11*(1-(A41-A21)/40),0);
选2:=CROSS(C11,选1) AND CLOSE/REF(CLOSE,1)<1.03;
选3:IF(选2,ZS*1.03,ZS),colorGREEN;

下载地址(点击下图进入下载地址网页)

    大智慧的分时主图指标源码下载

·上一软件:搓揉线选股公式
·下一软件:大牛股启动

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网发布的公式指标和股票软件绝大部分是来源于各大论坛,例如:LX论坛,LQZ论坛,CH论坛,MA**论坛等,谢谢各位老师的原创软件。为了达到最快的下载速度,推荐使用网际快车迅雷下载本站软件。
* 请一定升级到最新版WinRAR3.61才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
* fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
* tnc和tni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式公式,可以用通达信公式编辑器5.0版导入,推荐通达信短线极品版本;
* hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称 ,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式(FNC格式)大智慧股票池,同花顺公式(hxf格式),操盘手公式(daf),飞狐公式(alg),博易大师公式,文华公式等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

声明:本站所有软件和信息均免费。站内所有广告,如有收费行为,均与本站无任何关系!请广大网友小心谨慎。
Copyright © 2003-2008 . All Rights Reserved .
页面执行时间:3,421.87500 毫秒